No MIDI signal being recognized

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).

  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.

Postby Aeriq » 03-30-12 5:13 pm

Hello All.

I recently discovered Synthesia and I'm excited to get started, but I've managed to hit some speed bumps along the way. Nothing's ever easy. I purchased a E-MU Xmidi 1x1 to connect my Macbook (running snow leopard) to my dusty old keyboard. This is a Keytek TB600M, a company that I'm pretty sure has long past. The keyboard only has a MIDI-OUT port. When plugged into my macbook, the light within the E-MU Xmidi 1x1 turns on, but the light stays solid when pressing keys (I've tried using both midi-in and midi-out on the E-MU cable to no avail). There's nothing to say my computer is recognizing anything.. nothing happened when I plug it in, except for that little light turning on.

Could this be because I'm using a crappy old china brand keyboard? Or the cable? My computer?
Any help would be appreciated.

Thanks!
Aeriq
 
Scores
Posts: 1

Postby Nicholas » 03-30-12 10:26 pm

It could be the keyboard.

Though, I am unhappy to report that while I'd been happily recommending the Xmidi 1x1 for something like six years now, in the last two months there has been a huge increase in the number of reports I've heard from people having trouble with it. That is, from zero reports in six years to several all at once in the span of a couple weeks.

I contacted E-MU and they confirmed something strange seemed to be happening. That was already a couple months ago, and the reports have died back down to almost nothing again, but I'm worried that here-and-there some of the same bad batch of adapters are lingering on store/warehouse shelves.

The behavior you described is the same I've heard from others: the light turns on, but never flashes to indicate data is being sent. E-MU recommended trying to acquire a replacement through the store you ordered from, or failing that, through E-MU support. I tried to press them about the lengths they might be able to go to in order to avoid making this a very negative experience for customers, but they confirmed customers would have to cover shipping charges themselves to send it back to E-MU.

Each time I hear about this, I feel really bad about maintaining the recommendation on the site. I was hoping the problem would go away on its own, quickly. And while it has certainly all but disappeared, each time someone reports they're having a poor experience, I can't help but feel completely responsible. I am sorry.

Depending on where you got the adapter, I'd say return it to maybe try a different brand. Or, if you don't mind throwing the dice again and hoping not to get another dud, you could get a replacement Xmidi 1x1.
Nicholas
 
Scores
Posts: 8341


Return to Help and Bug Reports

Who is online

Users browsing this forum: No registered users