10.2 Preview r3659-r3715 - Lots of stuff

Archived development update discussion from past versions
Archived development updates.
Nicholas
Posts: 12289

Post by Nicholas » 08-13-15 5:26 pm

Hmm, strange. Is the keyboard still showing up at the bottom of the title screen as being enabled? Does a computer restart solve the problem? (It's rare that it does, but with the strange hiccups being introduced by Windows 10, it wouldn't hurt to try.

Nicholas
Posts: 12289

Post by Nicholas » 08-13-15 5:59 pm

PREVIEW r3715
Download from the pink box above.

Changes since last time
  • German language fix. (Thanks monkel!)
  • Updated translations for all the new language in 10.2.
  • A few fixes to get things building in 64-bit mode for the iPad.
  • Continued to improve support for the Jamboxx.
Unless it crashes, this is going to become the final version of 10.2 early next week. :D

seanjohnson
Posts: 2

Post by seanjohnson » 08-14-15 12:36 pm

seanjohnson wrote:Hello, yesterday I was doing an evaluation of your production version with Win10 and had no audio, so I came here and tried your PREVIEW r3659. This solved the Win10 audio problem and I was enjoying it so much I purchased a key and a few songs. After entering the key, the preview version stopped recognizing my Midi-keyboard. I read somewhere that it needs to reacquire the midi connection thru restart. So I shutdown the app and disconnected the midi keyboard. Reconnected, and started the app...no help there.

Any ideas?
Nicholas wrote:Hmm, strange. Is the keyboard still showing up at the bottom of the title screen as being enabled? Does a computer restart solve the problem? (It's rare that it does, but with the strange hiccups being introduced by Windows 10, it wouldn't hurt to try.

Thank you. I had restarted the app a few times and pc had hibernated a few times between, but yes rebooting the machine worked. I should know by now that rebooting is the always the first Microsoft fix.

Loving this app, so much fun. Thanks.

Korados
Posts: 62

Post by Korados » 08-15-15 10:30 am

I have a new problem now in r3715! Every few measures the scrolling of the notes is stuttering. I tried several Midis of different sizes but it doesn't matter what I choose, the screen always stutters.

kiwi
Synthesia Donor
Posts: 1178

Post by kiwi » 08-15-15 10:36 am

Translation error:
"Particle effects" in options =>in french: "Effets de particules"

Birdman87
Posts: 60

Post by Birdman87 » 08-15-15 11:28 am

Korados wrote:I have a new problem now in r3715! Every few measures the scrolling of the notes is stuttering. I tried several Midis of different sizes but it doesn't matter what I choose, the screen always stutters.

Try switching from open gl to dx9 or backwards in the synthesia settings, that always fixed my problem.

You can access synthesia settings by holding shift when opening synthesia

Korados
Posts: 62

Post by Korados » 08-15-15 6:42 pm

No, this didn't work. OpenGL even makes it worse. I resetted the settings of my graphics card again because this was the problem last time, but this time it didn't help.

Nicholas
Posts: 12289

Post by Nicholas » 08-15-15 8:05 pm

kiwi wrote:Translation error
Thanks!
Korados wrote:Every few measures the scrolling of the notes is stuttering.
Did you mean the sheet music or falling notes? How big a stutter: one frame or several? If you press F6, does the frame rate drop during the stutters?

Korados
Posts: 62

Post by Korados » 08-17-15 4:37 pm

I mean the falling notes. Strangely, they stutter roughly every 3 three seconds. The framerate drops to 116 during the stutter. The framerate drop also occurs in the menus, but it's only visually
noticeable when the notes are falling.

Nicholas
Posts: 12289

Post by Nicholas » 08-17-15 4:54 pm

Try this:
  • Open the configuration window (hold shift while starting the dev preview)
  • Select "Midi.DeviceCheckMilliseconds" in the list.
  • Add two zeroes to the value, making it "300000".
Does that make the stutter go away? (Instead of checking your MIDI devices for changes every 3 seconds, it will now only check once every 5 minutes.)

Korados
Posts: 62

Post by Korados » 08-18-15 11:13 am

Sorry but this didn't work, too. Could you give me a link to the previous Synthesia 10.2 builds, please? I deleted the previous builds but
I'd like to check if the error only occurs in r3715.

Nicholas
Posts: 12289

Post by Nicholas » 08-18-15 7:56 pm

Assuming you're looking for the Windows versions: r3659 r3690 r3699 r3715

Korados
Posts: 62

Post by Korados » 08-18-15 9:38 pm

I'm running Windows 8.1 on my PC. I'm afraid to tell you that I had the problem on all builds now. I tried to take out the appdata folder to see if that works, but this didn't help, too.
I wanted to make a screen video for you but when I try to make one, the FPS of Synthesia get unstable and drop to 95. But this also happens on 10.1,
so I guess it's not an important issue. But the stuttering in 10.2 probably is because I find it irritating. What could be the cause of this? My graphics card?
I already resetted all settings to default.

Nicholas
Posts: 12289

Post by Nicholas » 08-18-15 10:04 pm

This is just a hunch, but try turning off the "System.JamboxxEnabled" setting from the configuration window. Does that prevent the stutter?

Korados
Posts: 62

Post by Korados » 08-19-15 9:33 pm

Bulls Eye! The stutter is gone now! I'm glad we found the problem. Thank you very much! :D But what does the Jamboxx do?

Nicholas
Posts: 12289

Post by Nicholas » 08-20-15 12:00 am

That stutter is (apparently) from Synthesia checking all of your connected USB devices to see if one of them is a Jamboxx. In my own testing it was never so pronounced. I'll try to see if it can be pushed onto a low-priority thread or something so that it doesn't impact frame rate anymore.

Otherwise, the Jamboxx is a neat breath instrument that you can now also use inside Synthesia. I've been working with the Jamboxx folks for a few months now to get things integrated.

Locked