10.3 preview r3968, r3974 - Platform Update

Archived development update discussion from past versions
Archived development updates.
Korados
Posts: 62

Post by Korados »

I really did this. The first thing I did when I downloaded the new build was that I opened the configuration panel to check if every setting is like I want it to. I still think it's because of OpenGL!
KaleidonKep99
Posts: 54

Post by KaleidonKep99 »

The note drawing limit problem is here again, just like in the previous versions of the Video Creator!

Pics:
Spoiler:
Image
Image
Image
Nicholas
Posts: 12489

Post by Nicholas »

Correct. Use the Video Creator instead. :lol:
PHIDIAS
Posts: 136

Post by PHIDIAS »

what just happened @@
Crashed
Synthesia r3974 Crash.dmp
(377.47 KiB) Downloaded 895 times
By the way to alignment wasnt so good when i launch synthesia.But after i press the resize button (near close application "X") then alignment will be "fixed".
Also when i play some songs it will drop frames from 60 to 30 , even 22 or maybe 14.

sorry for bad english
KaleidonKep99
Posts: 54

Post by KaleidonKep99 »

Nicholas wrote:Correct. Use the Video Creator instead. :lol:
But what if I want to play it in real-time? :(
Nicholas
Posts: 12489

Post by Nicholas »

KaleidonKep99 wrote:But what if I want to play it in real-time? :(
You could always play the rendered video. ;) I'm curious to hear a good answer to why you'd still need to play a million+ note song back in real time. Once rendered, there isn't anything you can't do in a video player that you normally use Synthesia for. And the typical use of Synthesia with Black MIDI is to create videos. If you've got a good reason, I'm all ears... but I don't see one.
PHIDIAS wrote:what just happened @@ Crashed
Were you playing anything very intensive? I took a look at the crash report, but it was inconclusive. The thread that crashed had a completely empty stack, so I couldn't see where the problem was.
PHIDIAS
Posts: 136

Post by PHIDIAS »

Well it is a song:
https://www.youtube.com/watch?v=P63oFD9gL64
It can run without problem on 60fps in Synthesia 10
But i cant run it on 60fps in Synthesia 11 @@
Also when i play it in 11, sometimes virtual piano in the bottom and the tool bar in top will disappears.
~No idea where i get this midi...
35,611 notes
Nicholas
Posts: 12489

Post by Nicholas »

Yeah, this is more the kind of song you'd want to run through the Video Creator. Although, I did fix the bug that was causing the tool bar to flicker/disappear.
Locked