[Windows] Fixing latency with Cubase

Have questions? Just saying hello? This is the place.
No explicit, hateful, or hurtful language. Nothing illegal.
Post Reply
PeterP
Posts: 1

Post by PeterP » 07-22-17 11:20 am

Hi,

If you're using Windows, struggle with latency and happen to have access to Cubase (or other DAW) and a decent sound card then this is a step by step guide how to fix it.

1) Install a Midi Loop back driver that supports multiple channels.
https://www.tobias-erichsen.de/software/loopmidi.html works well and is free.

2) Create two separate midi channels in loopMidi, let's call them "loopback piano" and "loopback metronome".

3) Open Synthesia and enter settings.
- Disable "Microsoft GS Wavetable Synth".
- Enable "loopback piano" and make sure that only "My Notes" and "Background Instruments" are ticked.
- Enable "loopback metronome" and make sure that only "Percussion" and "Metronome" are ticked.

4) Open Cubase and create two new Instrument Tracks.
- Let's call the first one "piano", and select HALion Sonic SE. Load a nice Piano patch. In the Track Inspector on the side; change midi input to "loopback piano".
- Let's call the second one "metronome", and select another HALion Sonic SE. Load a GM compatible Drum Kit patch. In the Track Inspector on the side; change midi input to "loopback metronome".
- Make sure that the "Monitor" button is lit on both tracks.

Cheers,
Peter

Post Reply