Metronome Mutes The Keys...

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
icuurd12b42
Posts: 45

Post by icuurd12b42 »

So, In free play, when you use the metronome, the keyboard volume drops quite drastically

Vid:
[youtube=https://youtu.be/CUJnwKs1KQw]https://youtu.be/CUJnwKs1KQw[/youtube]

I'm not really sure why this is happening, it's inconsistent, *some notes start as loud as they should but only for an instant. the last part of the video I'm slamming the key so the velocity should be maxed

Here I have isolated the Keys with my audio editor. In green, no metronome. In red, the places where the key notes are audible between beats, to show it's not an combined audio illusion...
SoundBug.png
SoundBug.png (16.86 KiB) Viewed 460 times


*It feels like there is volume normalization happening as it seems the louder beats are muffling the occasional "louder keys" in a delayed way
Nicholas
Posts: 12823

Post by Nicholas »

Which instrument (or MIDI output) are you using there? Is this with the built-in SoundFont?

Checking inside the MIDI for the 4/4 Rock 1 beat, there's almost nothing but note-on/off messages. And if it's the built-in BASS-based synth, we're not using any particular effects besides reverb (which can be turned down to zero via settings). It might have some built-in normalization, but I wasn't able to reproduce any large volume difference like your video just now using any of the instruments with that piano icon.
icuurd12b42
Posts: 45

Post by icuurd12b42 »

It's using the Built In Synth.

In the vid it's the saw tooth instrument, but it does it for every instrument I tried. short duration notes with instruments like piano is less noticeable.

It does not matter the Volume Scale or the reverb setting of the output

I thought maybe my KB is not sending the note with enough velocity
anote.png
anote.png (2.11 KiB) Viewed 369 times
But it also does it on the virtual keyboard**...

If you are normalizing the final wave output (then applying volume control) that may be the problem when suddenly the loudest thing playing is by far the metronome... You should normalize both keyboard and metronome independently before mixing them (not 100% sure on that it's been a while)...

Or a simpler solution, I would assume, add a volume control on the metronome. it's too loud right now imho. so the extra feature would help

Cheers

**BTW the virtual keyboard is not taking in fast clicks (I think the application is detecting a double click) and so ignoring every second fast click
Nicholas
Posts: 12823

Post by Nicholas »

icuurd12b42 wrote: 12-17-21 2:14 pmIf you are normalizing the final wave output...
For what it's worth, Synthesia has almost nothing to do with the actual output waveform. Outside of the reverb setting (which is a single number we pass into it), we treat the built-in synth like a black box just like any of the other reported MIDI devices in the system. We send it MIDI events and (hopefully!) audio is produced from your speakers. The BASS and BASSMIDI libraries handle that part for us and may be doing something internally to avoid clipping by adding compression or normalization, but those are details Synthesia doesn't have any control over.

Out of curiosity, what does your "Music Input" situation look like on the Settings screen? If you're using any virtual or loopback devices, maybe something is wired funny and you're getting duplicate messages? If two or more identical notes are being sent to the built-in synth, I could see the volume getting out of hand, which might trigger some built-in clipping protection.

On your input and output devices, do you have all of their volume scales set to 100%?
icuurd12b42
Posts: 45

Post by icuurd12b42 »

Everything is normal in the input screen. I have no virtual loopback setup. The processing stack is just My KB (the only one enabled), the usb driver and your app...

I'm getting similar muting with some instruments for some midi files I got off the web as well so it's definitely happening on the output end...

The metronome in practice mode has volume control which fixes the issue when set at 20%

So you think you can add the volume control for the metronome in Free Play? Seems like an easy workaround...

I'm also a bit confused why the metronome in Free Play does not have the regular metronome sound available in practice mode as well as the beat selection other than 4/4 and 3/4.
Nicholas
Posts: 12823

Post by Nicholas »

How strange. And you're using the built-in SoundFont with the built-in synth? Not a different SoundFont with a louder set of percussion? I'm guessing some limiter is being used inside BASS to avoid clipping, so the question is why the metronome in your copy of Synthesia generating louder output than mine. I just set the metronome to 100% during playback and still can't reproduce any of the limiting behavior your recording showed. :?

Regarding the Free Play "styles", many years before the recording feature was added, I had asked my music arranging friend to make a few of the types of beats you find on most personal keyboards. It was only after the recording feature was added recently that it started to make more sense to get metronome-like things in there. So the "clap" style was a stop-gap measure. The song metronome is dynamic and adjusts to changes in the time signature while the song is playing. The beat patterns on the Free Play screen are simply pre-recorded MIDI snippets that are played on a loop.

The idea of choosing any time signature there that you want would either involve an elaborate beat/style generator or simply convincing my music arranging friend to throw together a dozen or so more of them in the most common genres and time signatures that are still missing.
icuurd12b42
Posts: 45

Post by icuurd12b42 »

So, well I feel silly

Turns out when I disabled the Loudness Control Enhancement, as mentioned, to make sure that was not the problem, I was doing it for my Headphone which MS renamed Speakers. Loudness control was indeed the issue. That's where the normalization is happening.
2speakers.png
2speakers.png (12.74 KiB) Viewed 253 times

Volume control would be nice on the Freeplay metronome though...
Nicholas
Posts: 12823

Post by Nicholas »

No worries. That sound device stuff in Windows 10 is the worst. Since 8 they've tried to be much more "helpful" when adding/removing things like Bluetooth headsets and it's a complete disaster. It chooses the wrong default every time and I've had to completely restart the machine (on more than one occasion) to correct some bizarre configuration hiccup where suddenly an app simply can't open a recently connected sound device.

A volume control for the currently playing style in Free Play is a good idea. I just added it to line 86 (under the ~15 line "Free Play [recording] improvements" umbrella). So with any luck, that'll make it into the next update: Synthesia 10.9.
Post Reply