Tempo stability

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
karasunouta
Posts: 3

Post by karasunouta »

Hello.
I've been using Synthesia free (ver. 9) for a while and now considering to buy the paid version.

But one thing bothers me that Synthesia 9 loses tempo stability on playing once in a while.
As a result, for example, captured video of Synthesia 9 is sometimes longer than the audio file of the same song exported from a DAW.

Could you tell me wheather Synthesia paid version had overcomed this issue or not yet?

OS: Windows 10 Home
Synthesia version: 9.0.2495
Bavi_H
Posts: 54

Post by Bavi_H »

Do you have an example MIDI file I can look at?
What is the length of the video captured from Synthesia and the length of the audio exported from the DAW?
How do you capture video of Synthesia?
What DAW do you use to export an audio file?
karasunouta
Posts: 3

Post by karasunouta »

Thanks for your reply.
That means this isn't a known issue?

I'll attach an example MIDI file that once caused the trouble.

> What is the length of the video captured from Synthesia and the length of the audio exported from the DAW?

I think it won't make much sense due to their offset time are different each other.
As I recall I noticed the problem when pasted the two files (captured Synthesia GUI mp4 and WAV) on a movie maker software "Hitfilm Express" and played for few minutes.
Because their tempo gradually shifted each other though their actual play (ignoring offset time) had started just the same time.

After that, I played Synthesia 9 on several cases and sometimes felt that it's rythm goes a little unsteady.
So I thought this time shift issue would be caused by Synthesia side, and it'd be perhaps one of known issues, and I wrote in this forum yesterday.

> How do you capture video of Synthesia?

I used FrashBack Express Recorder.
https://download.cnet.com/FlashBack-Exp ... 65043.html

> What DAW do you use to export an audio file?

Cakewalk.

Any advice will help.
Thank you!
Attachments
[スパルタローカルズ]水のようだ-Piano.mid
(17.58 KiB) Downloaded 4 times
Bavi_H
Posts: 54

Post by Bavi_H »

I don't know yet what is causing the difference for you.

I haven't tried to make a video, but so far I tested playing an audio file exported from Cakewalk at the same time as the MIDI file playing in Synthesia, and as far as I can hear they stay in sync for the entire song.

Details:
Spoiler:
I exported an audio file from Cakewalk as follows:
  • I opened your MIDI file in Cakewalk (version 2018.11, build 31, 64 bit).
    I went to the Insert menu, and selected Soft Synth, Cakewalk TTS-1.
    I changed the two MIDI tracks to output to Cakewalk TTS-1.
    In the File menu, I went to Export, Audio and exported an audio file.
I opened the audio file in Audacity (2.2.2 build date Feb 14 2018). (The audio is very quiet, so I used the Effect menu, Amplify command, default settings to amplify the audio.) In Audacity, I pressed Space key to start playing, and then right at the 9th beat, I pressed the P key to pause.

I opened your MIDI file in the paid version of Synthesia I have (Synthesia 10.8.5686 running on Windows 8.1). (The MIDI file is very quiet, so I used the Music Output page, volume scale, maximum setting to make it sound louder.) I started the song playing, then switched to Audacity. Right at the 9th beat, I pressed the P key to unpause Audacity.

As far as I can hear, the audio from Audacity and Synthesia stayed in sync for the entire song.

I did the same test with Synthesia 9.0.2495. In its Synthesia Configuration program, I tested with the video settings on DirectX 9 and OpenGL, but both stayed in sync as far as I could hear.
karasunouta
Posts: 3

Post by karasunouta »

Surprised! I'm glad to hear that you went so far for me.
Thank you very much!

Nevertheless as the trouble not occurred in your inspection, maybe this causes in my environment though my PC's spec is not bad (not perfect, also. Of cource).

I'll continuously use Synthesia 9 for a while and see how it works in other projects.
Post Reply