Page 1 of 1
Posted: 06-10-20 3:14 pm
by jaysig
Sent the following email some days ago. Copying it here:

We have an original iPad that runs Synthesia and lives on the keyboard.

In other words, we've had this version of Synthesia with iOS 5.1.1 for a long long time. It is many years since any new app or update has been installed on this ipad.

And, yet, somehow, yesterday Synthesia started crashing on startup.

Steps that I've tried: Soft restart iPad. Hard reboot iPad. Reinstall Synthesia. Checked usage and it has 2GB free.

Could it be a corrupted file? Reinstall should have taken care of that...

One thing we did some days ago, was to open a midi file on the internet directly in Synthesia. I cannot find that file in the iTunes "file sharing" view. Even though it is not visible, the file worked fine and is obviously stored somewhere. Could it somehow be the cause? (btw: how do I get a copy of that file onto my computer).

Thanks for reading

Posted: 06-10-20 3:17 pm
by jaysig
Copying Nicholas reply too:

Regarding the version of Synthesia that can still run on iOS 5.1.1, I'm rather stumped. To the best of my knowledge Apple hasn't released any sort of update for those devices in years. They've also made it impossible to update apps that old: in order to submit an update to the App Store, you must use the latest version of Xcode... which can no longer "target" an app for anything before iOS 8 or so. So the old version that is available is the only one there will ever be, unfortunately.

The problem is a strange one. Uninstalling and reinstalling the app should always be enough to essentially "factory reset" the app. The uninstall process wipes all data the app could have stored, so the reinstall should appear totally fresh. Restarting the iPad should clear out any strangeness. 2GB free should be enough for anything.

Files imported via iTunes File Sharing are placed in the "Inbox" folder in the app's internal sandbox storage, which is also wiped out by an uninstall/reinstall cycle. So I can't imagine that would be causing any trouble either.

So this is one of those strange cases where you've done everything right and there isn't any reason something should have broken in the meantime. How frustrating.

I wouldn't recommend this at all, but there is technically one troubleshooting step remaining: factory resetting the entire iPad. That feels like it might invite more trouble than it could solve. And as far as I can tell, it shouldn't be able to do anything that your other steps haven't already done... but those other steps should have already fixed the problem. So we're in a strange spot.

I wish I had better/more advice for you! Please let me know if I can help with anything else.


Posted: 06-10-20 3:37 pm
by jaysig
Further steps I tried:

Backup iPad.

Restore iPad. Install only Synthesia.
- Synthesia works.

Add all the midi songs via ITunes “File Sharing”
- Synthesia still works. The issue now is that all our other content is missing.

Restore Backup.
- Synthesia crashes on startup.

Delete all midi via “File Sharing”
- Synthesia still crashes. iTunes did not allow deleting of the “Inbox” folder so those files may be the issue.

Installed iExplore to try to remove “Inbox” but it was not able to see this on the file system.

So some progress but not quite there yet. Ideas welcome 😀

On a totally different note: Do not Restore an old device if you can avoid it. A good number of apps we had purchased are no longer available on the App Store and therefore cannot be installed. Also, the various media I had transferred onto IPad, in an ad-hoc manner, over the years are apparently not part of what Apple defines as a backup...

Posted: 06-11-20 5:09 am
by Nicholas
Wow, that's very interesting. I can't imagine what part of the Restore from Backup process would cause Synthesia to stop launching correctly.

Thanks for this detailed write-up!

Posted: 06-12-20 12:21 pm
by jaysig
My guess is either the «inbox» folder or the user data.

Is there any way to inspect or modify these?

Posted: 06-12-20 12:41 pm
by Nicholas
Only if you root the device, which I never recommend.

Posted: 08-28-20 2:35 pm
by jaysig
So I finally purchased a new device, an iPad Pro, and restored from the backup.

It is running very latest iOS.

Synthesia crashes on startup :cry:


Posted: 09-03-20 11:20 pm
by Nicholas
Wow, that is wild! If you don't restore from backup (that is, delete Synthesia then reinstall it from the App Store) does it still crash?