8.4r2242 doesn't remember/save my settings

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
FreeBird
Posts: 22

Post by FreeBird » 12-15-12 1:30 pm

Hi everybody,

I hope you can help me with the actual version of the game.

I've just update Synthesia to 8.4r2242. I can enter my registration code (Synthesia Learning Pack key), add users, add folders, change my MIDI settings, etc.
However, when I quit and run the program once again, all my settings have disappeared as if they were not saved.
Is that a bug with that latest version or is there a workaround ?

BTW I'm using :
Windows 7 Ultimate 64 bits 8 Go RAM
Korg microSTATION keyboard
Coolsoft VirtualMIDISynth soundfont player with SONiVOX GS250 soundfont

Thanks for your help,
^v^ FreeBird ^v^

P.S. I would like to download Synthesia's previous version but it doesn't seem to be available from the website... so I can't use Synthesia anymore. :(

Nicholas
Posts: 12331

Post by Nicholas » 12-15-12 3:42 pm

Hmm. If it's a new bug, this is the first I've heard about it. The new version has been downloaded about 38,000 times and that's a major problem, so it seems like this would be reported by now if it affected everyone.

The first thing to check is the log file, to see if any errors are being reported (or if there is even a log file present). If you open a "Run..." prompt (Windows key + R) and type "shell:appdata", it will open an Explorer window. There should (hopefully) be a Synthesia folder.

In that folder, are there any files? Were any of them modified recently? If the log.txt file is new (modified at the time you last ran Synthesia), does it contain any "[ERROR]" lines?

FreeBird
Posts: 22

Post by FreeBird » 12-16-12 6:16 am

Hi Nicolas,

I've found 0.8.3 r1732 in my archives so I've uninstalled 8.4 r2242 and then reinstalled 0.8.3 r1732. This previous version can save my settings without any problem.
I'm going to try to install 8.4 r2242 again as soon as possible in order to answer your question.

Thanks,
^v^ FreeBird ^v^

FreeBird
Posts: 22

Post by FreeBird » 12-16-12 7:08 am

I've installed again 8.4 r2242. My previous settings have all been wiped out by this install.
I launched Synthesia, created two users and then exited.
Files have been updated but settings have not been saved (users have disappeared from Synthesia) when I launch Synthesia again.
Here is the log file's content :
Spoiler:
[INFO ] 2012-Dec-16 13:01:13 Pre-log:
src\main.cpp:441: Starting main()
src\main.cpp:444: Initializing user settings system
src\main.cpp:447: Retrieving log filename
src\main.cpp:452: log filename: C:\Users\Réal\AppData\Roaming\Synthesia\log.txt
src\main.cpp:453: Constructing dynamic portion of popup error box message
src\main.cpp:457: Initializing logger

[INFO ] 2012-Dec-16 13:01:13 src\main.cpp:464: Initializing simple settings system
[INFO ] 2012-Dec-16 13:01:13 src\SimpleSettings.cpp:202: Loading settings list.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'settings' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\main.cpp:471: Starting Synthesia 8.4 - r2242
[INFO ] 2012-Dec-16 13:01:13 src\main.cpp:472: Built Dec 7 2012 04:18:38
[INFO ] 2012-Dec-16 13:01:13 src\main.cpp:477: Running in Windows Vista.
[INFO ] 2012-Dec-16 13:01:13 src\main.cpp:491: Command line: '"C:\Program Files (x86)\Synthesia\Synthesia.exe" '
[INFO ] 2012-Dec-16 13:01:13 src\main.cpp:523: Attempting to process the command line.
[INFO ] 2012-Dec-16 13:01:13 src\main.cpp:550: Initializing HTTP services
[INFO ] 2012-Dec-16 13:01:13 src\main.cpp:588: Creating shared state.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:262: Loading track settings file.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'tracks' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:265: Loading bookmark settings file.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'bookmarks' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:268: Loading saved scores file.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'scores' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:271: Loading users.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'users' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:274: Loading song progress cache.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'songProgressCache' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:277: Loading devices.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'multiDevice' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:281: Loading song info.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'songInfo' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:285: Loading watched folder list.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'folders' not found.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:289: Loading local auto-saved finger list.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'fingers' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:293: Loading default input bindings.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'default_bindings' not found.
[INFO ] 2012-Dec-16 13:01:13 src\SharedState.cpp:297: Loading current input bindings.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:130: 'bindings' not found.
[INFO ] 2012-Dec-16 13:01:13 src\UserSettings.cpp:149: Resource not found. Returning empty document.
[INFO ] 2012-Dec-16 13:01:13 src\libmidi\MidiComm.cpp:267: Adding device: 'microSTATION 1 KEYBOARD'
[INFO ] 2012-Dec-16 13:01:13 src\DeviceManager.cpp:141: Opening MIDI device (pass=0, id=1)
[INFO ] 2012-Dec-16 13:01:13 src\DeviceManager.cpp:141: Opening MIDI device (pass=1, id=0)
[INFO ] 2012-Dec-16 13:01:16 src\UserSettings.cpp:130: 'ui' not found.
[INFO ] 2012-Dec-16 13:01:16 src\UserSettings.cpp:130: 'colors' not found.
[INFO ] 2012-Dec-16 13:01:16 src\UserSettings.cpp:130: 'metadata_games' not found.
[INFO ] 2012-Dec-16 13:01:16 src\UserSettings.cpp:130: 'metadata_gmajor' not found.
[INFO ] 2012-Dec-16 13:01:16 src\UserSettings.cpp:130: 'metadata_exercises' not found.
[INFO ] 2012-Dec-16 13:01:16 src\UserSettings.cpp:130: 'metadata_classical' not found.
[INFO ] 2012-Dec-16 13:01:16 src\main.cpp:595: Checking if MIDI volume is muted or too quiet.
[INFO ] 2012-Dec-16 13:01:16 src\main.cpp:650: Initializing FreeImage library
[INFO ] 2012-Dec-16 13:01:16 src\main.cpp:653: Using FreeImage version 3.15.3
[INFO ] 2012-Dec-16 13:01:16 src\main.cpp:708: Setting state size: 1920x1080
[INFO ] 2012-Dec-16 13:01:16 src\main.cpp:713: Starting up GDI+
[INFO ] 2012-Dec-16 13:01:16 src\RendererBackendDirectx.cpp:474: Creating DirectX rendering backend.
[INFO ] 2012-Dec-16 13:01:16 src\RendererBackendDirectx.cpp:164: Creating device.
[INFO ] 2012-Dec-16 13:01:16 src\RendererBackendDirectx.cpp:180: Resetting device.
[INFO ] 2012-Dec-16 13:01:16 src\main.cpp:781: Creating startup screen.
[INFO ] 2012-Dec-16 13:01:16 src\RendererBackendDirectx.cpp:554: Starting main loop.
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:1006: Sending window destroy message.
[INFO ] 2012-Dec-16 13:01:59 src\RendererBackendDirectx.cpp:426: Lost device.
[INFO ] 2012-Dec-16 13:01:59 src\RendererBackendDirectx.cpp:441: Destroying device.
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:807: Returned from main loop, starting to shut down.
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:809: Cleaning up GameStateManager.
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:813: Cleaning up rendering backend.
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:819: Shutting down GDI+
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:825: Shutting down FreeImage library
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:829: Cleaning up state.
[INFO ] 2012-Dec-16 13:01:59 src\SharedState.cpp:355: Saving out track settings.
[INFO ] 2012-Dec-16 13:01:59 src\SharedState.cpp:358: Saving out song bookmarks.
[INFO ] 2012-Dec-16 13:01:59 src\SharedState.cpp:365: Saving scores.
[INFO ] 2012-Dec-16 13:01:59 src\SharedState.cpp:368: Saving users.
[INFO ] 2012-Dec-16 13:01:59 src\SharedState.cpp:371: Saving song progress cache.
[INFO ] 2012-Dec-16 13:01:59 src\SharedState.cpp:374: Saving devices.
[INFO ] 2012-Dec-16 13:01:59 src\SharedState.cpp:378: Saving auto-saved finger hints.
[INFO ] 2012-Dec-16 13:01:59 src\SharedState.cpp:383: Saving input bindings.
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:835: Shutting down Internet services
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:838: Shutting down simple settings.
[INFO ] 2012-Dec-16 13:01:59 src\main.cpp:841: Shutting down logger.
I'm going to revert back to 0.8.3 r1732 (waiting for a solution).

Thank you,
FreeBird.
Last edited by FreeBird on 12-16-12 7:44 am, edited 2 times in total.

FreeBird
Posts: 22

Post by FreeBird » 12-16-12 7:21 am

Hi again. I've reinstalled 0.8.3, re-created the deleted users, re-registered (learning pack key), played a song and exited. Every setting has been correctly saved (unlike with 8.4).

Here is the log using 0.8.3 :
Spoiler:
[INFO ] 2012-Dec-16 13:17:05 Pre-log:
src\main.cpp:370: Starting main()
src\main.cpp:373: Initializing user settings system
src\main.cpp:376: Retrieving log filename
src\main.cpp:381: log filename: C:\Users\Réal\AppData\Roaming\Synthesia\log.txt
src\main.cpp:382: Constructing dynamic portion of popup error box message
src\main.cpp:386: Initializing logger

[INFO ] 2012-Dec-16 13:17:05 src\SimpleSettings.cpp:187: Loading settings list.
[INFO ] 2012-Dec-16 13:17:05 src\main.cpp:400: Starting Synthesia 0.8.3 - r1732
[INFO ] 2012-Dec-16 13:17:05 src\main.cpp:401: Built Apr 6 2012 08:39:00
[INFO ] 2012-Dec-16 13:17:05 src\main.cpp:405: Running in Windows Vista.
[INFO ] 2012-Dec-16 13:17:05 src\main.cpp:419: Command line: '"C:\Program Files (x86)\Synthesia\Synthesia.exe" '
[INFO ] 2012-Dec-16 13:17:05 src\main.cpp:448: Attempting to process the command line.
[INFO ] 2012-Dec-16 13:17:05 src\main.cpp:476: Initializing HTTP services
[INFO ] 2012-Dec-16 13:17:05 src\main.cpp:487: Creating shared state.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:236: Loading track settings file.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:244: Loading bookmark settings file.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:252: Loading saved scores file.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:260: Loading users.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:268: Loading song progress cache.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:277: Loading devices.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:286: Loading song info.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:295: Loading watched folder list.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:304: Loading local auto-saved finger list.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:313: Loading default input bindings.
[INFO ] 2012-Dec-16 13:17:05 src\SharedState.cpp:322: Loading current input bindings.
[INFO ] 2012-Dec-16 13:17:05 src\DeviceManager.cpp:222: Opening output MIDI device (id=0)
[INFO ] 2012-Dec-16 13:17:07 src\libmidi\MidiComm.cpp:219: Adding device: 'microSTATION 1 KEYBOARD'
[INFO ] 2012-Dec-16 13:17:07 src\DeviceManager.cpp:168: Opening input MIDI device (id=0)
[INFO ] 2012-Dec-16 13:17:07 src\main.cpp:494: Checking if MIDI volume is muted or too quiet.
[INFO ] 2012-Dec-16 13:17:07 src\main.cpp:565: Initializing FreeImage library
[INFO ] 2012-Dec-16 13:17:07 src\main.cpp:568: Using FreeImage version 3.11.0
[INFO ] 2012-Dec-16 13:17:07 src\main.cpp:622: Setting state size: 1920x1080
[INFO ] 2012-Dec-16 13:17:07 src\main.cpp:627: Starting up GDI+
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:477: Creating DirectX rendering backend.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:109: Checking if device is acceptable.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:167: Creating device.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:183: Resetting device.
[INFO ] 2012-Dec-16 13:17:07 src\main.cpp:684: Creating startup screen.
[INFO ] 2012-Dec-16 13:17:07 src\RendererBackendDirectx.cpp:557: Starting main loop.
[INFO ] 2012-Dec-16 13:17:10 src\libmidi\MidiComm.cpp:219: Adding device: 'microSTATION 1 KEYBOARD'
[INFO ] 2012-Dec-16 13:17:13 src\libmidi\MidiComm.cpp:219: Adding device: 'microSTATION 1 KEYBOARD'
[INFO ] 2012-Dec-16 13:17:16 src\libmidi\MidiComm.cpp:219: Adding device: 'microSTATION 1 KEYBOARD'
[INFO ] 2012-Dec-16 13:17:19 src\libmidi\MidiComm.cpp:219: Adding device: 'microSTATION 1 KEYBOARD'
[INFO ] 2012-Dec-16 13:17:21 src\main.cpp:885: Sending window destroy message.
[INFO ] 2012-Dec-16 13:17:21 src\RendererBackendDirectx.cpp:429: Lost device.
[INFO ] 2012-Dec-16 13:17:21 src\RendererBackendDirectx.cpp:444: Destroying device.
[INFO ] 2012-Dec-16 13:17:21 src\main.cpp:697: Returned from main loop, starting to shut down.
[INFO ] 2012-Dec-16 13:17:21 src\main.cpp:699: Cleaning up GameStateManager.
[INFO ] 2012-Dec-16 13:17:21 src\main.cpp:703: Cleaning up rendering backend.
[INFO ] 2012-Dec-16 13:17:21 src\main.cpp:709: Shutting down GDI+
[INFO ] 2012-Dec-16 13:17:21 src\main.cpp:715: Shutting down FreeImage library
[INFO ] 2012-Dec-16 13:17:21 src\main.cpp:719: Cleaning up state.
[INFO ] 2012-Dec-16 13:17:21 src\SharedState.cpp:367: Saving out track settings.
[INFO ] 2012-Dec-16 13:17:21 src\SharedState.cpp:370: Saving out song bookmarks.
[INFO ] 2012-Dec-16 13:17:21 src\SharedState.cpp:377: Saving scores.
[INFO ] 2012-Dec-16 13:17:21 src\SharedState.cpp:380: Saving users.
[INFO ] 2012-Dec-16 13:17:21 src\SharedState.cpp:383: Saving song progress cache.
[INFO ] 2012-Dec-16 13:17:21 src\SharedState.cpp:386: Saving devices.
[INFO ] 2012-Dec-16 13:17:21 src\SharedState.cpp:390: Saving auto-saved finger hints.
[INFO ] 2012-Dec-16 13:17:21 src\SharedState.cpp:393: Saving input bindings.
[INFO ] 2012-Dec-16 13:17:23 src\main.cpp:725: Shutting down Internet services
[INFO ] 2012-Dec-16 13:17:23 src\main.cpp:728: Shutting down simple settings.
[INFO ] 2012-Dec-16 13:17:23 src\main.cpp:731: Shutting down logger.
As it worked great with 0.8.3, not at all with 8.4 and then great again with 0.8.3, isn't that what you'd call a bug ?

Petike79
Posts: 3

Post by Petike79 » 12-17-12 3:53 pm

Hy All,

I have the same issue. Any settings will be lost when I restart Sysnthesia. Please HELP!!!

Thanks.

Peter
a registered learning pack user :)

Nicholas
Posts: 12331

Post by Nicholas » 12-17-12 5:39 pm

Hrm. This is starting to sound more serious.

This is kind of a shot in the dark, but... Petike79, does your Windows user name contain any non-ASCII characters? Anything with an accent or other non-US English character?

I noticed in FreeBird's log postings that the path contained an "é" character. While Synthesia hasn't contained any Unicode-related bugs in a very long time, the settings loading/saving code saw a major revamp during 8.4 so it is possible something may have been introduced.

Petike79
Posts: 3

Post by Petike79 » 12-18-12 3:20 pm

Hy Nicholas,

I will check it and return to you with the result. The proposal sounds promising for me. Other hand UAC also has turned off, I 've admin rights . . . All other 'usual' stuff has been checked.

P.

Petike79
Posts: 3

Post by Petike79 » 12-18-12 5:18 pm

Dear All,

Nicolas is telling the solution : if the windows user name contains only the US characters, without any special key it solves the issue.

Personally I have created a Synthesia user for playing with this program and I set everything without any problem....

Kind Regards,

Peter

Nicholas
Posts: 12331

Post by Nicholas » 12-18-12 5:28 pm

Thanks for following up. That is unfortunate. (Synthesia is almost as popular in non-US countries as it is in the US. :? )

I had updated one of the third-party libraries used in Synthesia to the latest version for the 8.4 release and that appears to have introduced a file-loading quirk (still my fault though). It'll be fixed in the first development preview for Synthesia 9. Though something that major almost makes a case for an interim 8.5 release. Hmm.

FreeBird
Posts: 22

Post by FreeBird » 12-19-12 12:25 am

OK, I'll keep 8.3 and wait for 8.5/9 because I won't create a user account only to use one software.
Thanks,
FreeBird.

Nicholas
Posts: 12331

Post by Nicholas » 12-20-12 12:18 am

This is a big deal, so I'll try to get some update out very quickly. The holidays will delay things a couple days, but I'm hoping to have something for you to try in a week or two.

FreeBird
Posts: 22

Post by FreeBird » 12-21-12 12:47 am

Thank you very much.

FreeBird

Mirek
Posts: 1

Post by Mirek » 01-02-13 11:29 am

I've the same problem, so I'm waiting for a new version of Synthesia.

Zonata
Posts: 1

Post by Zonata » 01-06-13 2:43 am

Same for me, too bad I have just started to use the software and live it. Hope you can get this fixed soon.

Articlion
Posts: 4

Post by Articlion » 01-06-13 7:26 pm

This works on my Mac, but it doesn't work on my PC. I do live in Korea.

What was the deal with the letters? Why can't I save my data on my PC? Is there any way to circumvent this?

FreeBird
Posts: 22

Post by FreeBird » 01-18-13 12:33 am

Hi,

Have you found a solution to this bug ?

FreeBird.

Nicholas
Posts: 12331

Post by Nicholas » 01-30-13 1:26 am

Alright, sorry for the wait on this. If you try the latest development preview (r2257 or later) does it work now?

I don't have a great way to test it on my side, so I'm kind of shooting in the dark. Still, I'm pretty confident.

FreeBird
Posts: 22

Post by FreeBird » 01-30-13 7:57 am

I downloaded, uncompressed and tried preview r2257 and it still doesn't remember any setting, sorry.
Why don't you create a new Windows account containing international characters for testing purpose ?

Nicholas
Posts: 12331

Post by Nicholas » 01-30-13 12:41 pm

I just did that and I can (still) reproduce the problem, sorry.

The reason I was hesitant is that switching users to test something kind of breaks up the whole development flow (it can't be debugged without installing dev tools on the new account, etc.). I was hoping to get lucky in that first try -- I rolled the file saving/loading code back to exactly what it was in 0.8.3 -- but now that I wasn't successful, I'll do it the right way.

I'll check into it and hope to have a new build ready later tonight.

Post Reply