App crash when trying to set loop

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
MaxC246
Posts: 77

Post by MaxC246 » 10-11-13 11:02 pm

Loaded up the latest version on my iPad Mini from the App Store. Every time I tap the Loop button, when the Loop option buttons appear on the screen, no matter which button I touch, the app crashes and goes back to the home screen. I've tried touching every one of the Loop option buttons and they all cause a crash.

iPad Mini running iOS v6.1.3

I really hope there's a work around or I'm doing something wrong. Trying to learn a song of any length without looping seems pointless.

Thanks Nathan. (OK, I'm just messing with you this time. :lol: )

Nicholas
Posts: 12196

Post by Nicholas » 10-11-13 11:15 pm

That is a very serious bug! I am able to reproduce it on my side. I am very sorry! Crash bugs are the worst.

A partial workaround in the meantime appears to be dragging a loop out in the timeline first, and then using the buttons below to manipulate it. I haven't narrowed down exactly what is going wrong yet but it seems to be vaguely related to the loop interacting with the very beginning of the song (i.e. the start of measure 1). So long as you avoid that, you might experience fewer crashes.

This will absolutely be fixed in the next release. I am sorry again!

(It's curious that this doesn't happen in the desktop version. Strange.)

Nicholas
Posts: 12196

Post by Nicholas » 10-11-13 11:57 pm

Found and fixed. Just shoddy work on my part. I am very sorry. It's a good thing a new version is going out in a few days. I hate the idea of a showstopping crash bug living in the live code.

It did have to do very specifically with the loop touching the start of the song. So long as you don't let that happen, you should be all set.

MaxC246
Posts: 77

Post by MaxC246 » 10-12-13 1:07 am

Man, talk about service! Found and fixed the bug in less than 45 minutes! Impressive, good sir.

You're right, I was trying to start the loop at the first note. I'll just avoid that until you get the new release out. How did I manage to find that bug so quickly? Are others just not using the Loop function, or are there not many people using the app in iOS yet?

Thanks again Nicholas. You rock!

Max.

Nicholas
Posts: 12196

Post by Nicholas » 10-12-13 1:21 am

MaxC246 wrote:How did I manage to find that bug so quickly? Are others just not using the Loop function, or are there not many people using the app in iOS yet?
I have no idea. Let's assume the bug just went out in the last release, 30 days ago. Apple is reporting that 50,589 people have downloaded the most recent version for the iPad. It seems like someone should have spotted that sooner than 30 days later. :?

Nicholas
Posts: 12196

Post by Nicholas » 10-12-13 1:59 am

Buh. Wow, if I felt bad before...

One of the neat things about the TestFlight SDK that I use with the iPad version of Synthesia is that crash reports are automatically sent in and presented in a way that is very easy to categorize and look up precisely where problems are happening (and on which generation of device, which dates, etc.)

All of that is assuming you actually look at your app's dashboard... *sigh*

I can now confirm that "someone" else had, in fact, run into the same problem. A lot of someones. Something like 1,700 crashes on that exact line of code in the last 30 days. I wonder what that says about the state of people feeling helpless with respect to app crashes on tablets, that it could happen so many times with only a single person (with a history in the forums) reaching out to me.

I just added a few steps to my various processes/checklists to make sure this never happens again.

MaxC246
Posts: 77

Post by MaxC246 » 10-12-13 11:50 am

Well, my ego likes knowing that I've contributed another little something to your masterpiece.... even if the contribution was a complaint. :)

Post Reply