MIDI input is echoed to MS Wavetable Synth

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
Pianotehead
Posts: 319

Post by Pianotehead » 03-30-14 12:11 am

I'm having a huge problem using my piano as a MIDI out device in Synthesia. Everytime I enable MIDI out, everything I play on the piano is echoed in Synthesia, as it seems, by the Microsoft GS Wavetable Synth, even though the Microsoft Synth is turned off as an output device. I can clearly hear it, when I turn up the volume above 100%.

Is there no way of preventing this input echoed as output? I can't see any such options in the settings. This is inconvenient, I would like Synthesia to play one track on my piano (as we all know General MIDI sucks, it's nowhere near something musical) while I play the other track(s.) Under the circumstances I've described, I can't do that.

Pianotehead
Posts: 319

Post by Pianotehead » 03-30-14 11:26 am

Update I downloaded the latest development version, and set Local Control to OFF on my piano (Casio PX-5S.) That seems to have solved the issue. Did you make any changes to the MIDI handling section of Synthesia's code? I thought I had tried to set Local Control OFF, and then it didn't work. Do you have any experience with the latest Casio's the PX-5S or PX-350? The MIDI facilities of the PX-5S are pretty advanced, but that means also hard to control!

Nicholas
Posts: 12054

Post by Nicholas » 03-30-14 3:35 pm

Hmm, I'm trying to imagine what might have changed in that preview to fix the problem. When you mention quiet notes, the only thing that comes to mind are lighted keys. The way those work is by sending out a note to a device with the lowest possible volume. On some keyboards you can still hear it quietly when the volume is turned up. If you had key lights enabled somewhere (on the Windows synth?), that might have been happening.

Otherwise, it's good to hear you're back up and running at least. Even if I don't know what caused it. :D

Pianotehead
Posts: 319

Post by Pianotehead » 03-30-14 5:11 pm

Your theory is not an unlikely explanation, I don't know what caused it. I do know, that it matters on which channels the tracks of the MIDI file are set. My piano has voices on channels 1 - 4. If a track of an incoming MIDI is residing on channel 1, it will be played with the voice of channel 1, a track on channel 2, will trigger the voice on channel 2, and so on. I found that out, when Synthesia always layered piano and strings. I used to have strings on channel 2 of the piano, and one of the tracks, usually the bass track, was set to channel 2. This happens even when the piano's channel/voice is turned off. The purpose of this setup is to be able to layer many voices.

The MIDI I was using was set to channel 3, 4, and 5, it had three tracks. I don't know which MIDI event the piano is listening for on channel five. That may well have resulted in some unpredictable behavior. Now I'm careful to set the tracks of my MIDI files to channels 1 - 3, as I usually don't have more than three tracks, and set the corresponding channels of my digital to Grand Piano. This way everything works out fine.

Post Reply