Page 1 of 1

CoolSoft Coolsoft VirtualMIDIsynth not detected

Posted: 12-16-15 6:27 pm
by Pianotehead
I'm sure this is not a Synthesia problem, since the VirtualMIDIsynth doesn't show up in Notation Composer either. I have Windows 10, and everything was working fine, until I installed the last big update, think it was a new version of Windows 10 altogether. At least it took forever to download and install, with numerous restarts.

Before this big update, I actually had a different problem with NC. Then the Microsoft GS Wavetable Synth was silent, but Coolsoft VirtualMIDIsynth worked. I know that Notation complained to Microsoft on the MS forum, claiming they had changed something regarding MIDI in Windows 10, causing their code to be no longer working, at least not with GS Wavetable Synth. However this has been fixed, and now Composer works with the MS synth, but not VirtualMIDIsynth anymore, and neither with Synthesia, as I've explained earlier.

Now I do not intend this thread to revolve around Microsoft or applications from other vendors. I'm just curious if someone has run into similar problems recently. Something seems to have gone wrong in this last Windows 10 update, but I don't know what. The CoolSoft page itself says, and I quote, MIDI management under Windows became a nightmare after Windows Vista.

Re: CoolSoft Coolsoft VirtualMIDIsynth not detected

Posted: 12-27-15 5:48 am
by kiwi
I had the same problem on win 7 years ago but i don't remember how i solved it.
In case of try to disable antivirus and launch synth├ęsia.

Re: CoolSoft Coolsoft VirtualMIDIsynth not detected

Posted: 12-27-15 10:19 am
by Pianotehead
Thank you kiwi, actually I have solved the problem, simply by uninstalling and reinstalling VirtualMIDISynth. I intended to update the original post to reflect that, but obviously I forgot to do so. :(

Re: CoolSoft Coolsoft VirtualMIDIsynth not detected

Posted: 12-28-15 8:06 am
by kiwi
Ah good to know that uninstaling solved the problem :)