Why do I need to hold pedal to hear the song?

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
littlepuppie
Posts: 54

Post by littlepuppie » 01-05-18 8:54 pm

Basically lets say I download the Pokemon theme song midi and I want to listen to the piece first on the Digital Piano, it wont work because in order to work I need to hold the pedal and then I can hear the piece. Why is that? How do i set it so it play like normal without me holding the god dam pedal lol. Not all midi do this but I say 90% of midi does it :(

Do you know why this happens? Is there a setting I need to tweak? appreciate the help.

Nicholas
Posts: 12035

Post by Nicholas » 01-06-18 1:15 am

That's a very strange problem. If you head over to the Settings --> Shortcuts screen, if you scroll down slowly while looking at the right-hand side of the list, do you see any mention of a pedal there?

Are any of the built-in songs behaving that way? Or is it only songs that you found elsewhere? (Which MIDI keyboard/adapter are you using?)

littlepuppie
Posts: 54

Post by littlepuppie » 01-06-18 7:08 pm

No, no pedal mention.

All the built in songs are 100% fine but 90% of the midis I downloads are not fine.

I use the wireless MIDI adapter.

Nicholas
Posts: 12035

Post by Nicholas » 01-10-18 2:45 am

Which Wireless MIDI adapter? Which keyboard? Are you running on PC, Mac, or iPad?

I'm still completely at a loss. Is this when you play the song in "Watch and Listen Only" mode?

When you say "... and then I can hear the piece", do you mean the falling notes are still falling but the only way to hear any sound is by pressing the pedal? (That is, Synthesia isn't actually stopping/pausing the song, correct?) If that's the case, this sounds like it might be a hardware issue. If you use a wired connection with your piano, does the problem still happen?

littlepuppie
Posts: 54

Post by littlepuppie » 01-10-18 6:54 pm

I use this https://www.andertons.co.uk/yamaha-md-b ... amEALw_wcB

Kawai es100
and iPAD PRO 12.9

Yes only 'Watch and Listen only' mode. I need to press the pedal to hear the song and if i dont, the notes just fall and i cant hear anything. ;(

Nicholas
Posts: 12035

Post by Nicholas » 01-10-18 8:34 pm

The adapter and iPad both sound like they're doing their job just fine.

I wonder if there isn't a weird setting on the keyboard. Or maybe the pedal's polarity got a bit confused? (When you play notes on the keyboard without Synthesia, does the pedal function normally?)

What is Synthesia's behavior if you first turn off your keyboard, unplug the pedal, and then turn the keyboard back on? Is it still silent?

littlepuppie
Posts: 54

Post by littlepuppie » 01-13-18 9:18 pm

Yes when I press notes and play pedal without Synthesia it sounds perfeectly normal HOWEVER when MIDI is connected it sounds very high its weird regardless if everything is working correctly it will always sound different when midi is connected. why is that? its sounds sooooo bad -_-
maybe i need to make video for you but do you know what im talking about lol sortry for my bad englands

Nicholas
Posts: 12035

Post by Nicholas » 01-20-18 3:23 am

The bad sound may be because you're getting doubled-up notes: one from your own key press and one from Synthesia.

You can usually solve that by doing one OR the other of the following (NOT both) after choosing your keyboard from the Music Output list on the Settings screen:

A. Enable the "Prevent local notes" option.
- OR -
B. Turn off the "My Notes" option.

(If you do both, you may not hear any sound from your keyboard at all!)

littlepuppie
Posts: 54

Post by littlepuppie » 01-20-18 9:13 pm

Ok thanks that worked however I still need to hold the pedal down still in order to listen to the midi piece. This is really frustrating. Have you found the solution yet? :oops:

Nicholas
Posts: 12035

Post by Nicholas » 01-21-18 3:43 am

I still don't have any idea about the pedal problem. Are you able to use any other MIDI-enabled apps to send the same songs out to your keyboard? Do they demonstrate the same problem? That would help rule out whether it was trouble with Synthesia or something else.

Post Reply