10.5 preview r4442 - Fixes for the Fixes

Try new versions before anyone else!
Always the latest dev version: [ win ] [ mac ] [ android beta opt-in ]
Please report comments and bugs!

Your data hasn't disappeared: development previews store their data in a different place. Details here.

Postby Nicholas » 01-29-18 9:24 pm

SYNTHESIA 10.5.4442
Download from the pink box above.

  • While splitting a part into hands, that part will now be played as you pan through the song. This can be muted by clicking the new speaker icon at the top-right corner of the screen.
  • The screen that appears when a MIDI device unexpectedly disconnects now shows a "Bluetooth Settings" button on supported platforms.
  • The "Bluetooth Settings" button (on the Settings screen and device disconnect screen) will now appear on macOS 10.10 or later. Clicking it will launch the "Audio MIDI Setup" app and display instructions on how to pair Bluetooth MIDI devices.
  • The direction and column used for sorting your scores on the "Points Earned" tab are now preserved between songs and app sessions.
  • Labels show on all notes again, by default. (Not showing all of them in 10.4 was an unpopular change!) If you prefer labels to only be shown for notes in the song's current key, choose "Settings → Gameplay → Note Labels → Use Song's Key".
  • The colors used by the sheet music display (background, highlights, matched notes, etc.) are now controlled by colors.xml, so they can be modded.
  • The score window is now more consistently positioned below the sheet music display.
  • Optimized away a source of frame rate drops that could occur each time a new measure was displayed for the first time or the tempo changed.
  • Dragging to pan works again on the custom hand assignment screen.
  • Fixed a crash during app exit that occurs in Windows 10 build 17063 and later.
More fixes to come, but wacher is right: this needs to get out the door as soon as possible to help the Windows Insider users.
Nicholas
 
Posts: 11668

Postby wacher » 01-30-18 6:31 am

1.000.000 x thanks :D
wacher
 
Posts: 27

Postby meirppp » 01-30-18 11:10 am

Wonderfull. I already using the first thing you mentioned.

Thanks a lot

Meir
meirppp
 
Posts: 25

Postby Tiothae » 01-31-18 5:31 pm

I've run into a bit of a problem on r4442 - Synthesia is no longer detecting VirtualMIDISynth for me on Windows 10 (build 16299 if that affects it at all). I could get around the issue on the previous version by renaming win10-midi.dll, but that doesn't seem to help now, nor does having the file there intact. Any ideas on what I can do so it pops up again?
Tiothae
 
Posts: 4

Postby Nicholas » 01-31-18 8:39 pm

Are you sure you're renaming the win10-midi.dll in the r4442 folder (and not the usual "Program Files (x86)\Synthesia" folder)?

One way to be sure:
1. Hold your Shift key while launching r4442 to open the configuration window.
2. Find the "Midi.UseWinRTMidi" setting in the list.
3. Remove the check from the Value box.

That should be it. Once you close the configuration and start the dev preview normally, hopefully VirtualMIDISynth will show up again.
Nicholas
 
Posts: 11668

Postby Tiothae » 02-01-18 2:29 pm

Thanks a lot for the information! That appeared to fix it after I re-installed VirtualMIDISynth after changing this setting.
Tiothae
 
Posts: 4

Postby Korados » 02-11-18 4:14 pm

Sounds like a great update but where can I get the new colors.xml? Or is the one available in the modding thread the same?
Korados
 
Posts: 57

Postby Nicholas » 02-11-18 4:44 pm

The one in the pink box at the top of the modding thread is updated (automatically during the build process) whenever we post a new dev update or official version. So you can always count on it being current.
Nicholas
 
Posts: 11668

Postby KaleidonKep99 » 02-20-18 4:18 pm

Would it be possible for you to add a menu item under the "Music devices" tab for the WinRT support, to allow newbies to switch between WinRT and WinMM without having to open the configurator?
KaleidonKep99
 
Posts: 46
Location: Cagliari, Sardegna, Italy

Postby Nicholas » 02-20-18 8:56 pm

Progress Update!
There is enough previously-unannounced info here to call it an update. This post describes the bulk of the "More fixes to come" I mentioned in the top post. :D



We're actually switching back to MME by default in Synthesia 10.5. It will be a split system where it'll use MME for most things, but be able to conditionally enable the new UWP MIDI stuff when the user clicks the button that says "Search for Bluetooth Devices". And even then, Synthesia will be using both MIDI APIs simultaneously with the new stuff only being used for Bluetooth devices. (UWP is one of our largest sources of crashes now. Hopefully limiting its use to only Bluetooth MIDI users will mitigate things.)

We'll keep a configuration option for people that want to use UWP for everything. That's useful for Windows 10 users struggling with MME as Microsoft appears to be adding new bugs to the old stuff each time a big Windows 10 update is released. We're in a weird situation right now where both APIs are semi-broken on Windows 10 so there isn't a right answer for everyone (except to use Windows 7 or 8)! :lol:

I've been in touch with a couple of the project leads at Microsoft in charge of the WinRT MIDI layer and have sent along a few of the mini-dumps (crashing deep in their code). I haven't heard anything definite back, but they've said they can confirm that something is wrong. Hopefully as more of the big Windows 10 updates roll out and their code starts to mature a little, things will get less terrible on the UWP side. Some day it might make sense to enable it by default for everything again. In the meantime, that day is not today. :?

Also, because the built-in GS synth is either high-latency under MME or crackles and pops under UWP, I've been experimenting with possibly licensing Un4seen's BASSMIDI and integrating it directly into Synthesia. (This will also mean much better sound in Synthesia for Android.) This will be the first time a new feature has allowed us to get rid of an FAQ answer altogether!

So, between a new synth that works better everywhere (with SF2 support and hopefully SF3 support soon), MME by default (so VirtualMIDISynth, KeppyDrv, etc. are visible by default), but still support for UWP (for those early Bluetooth MIDI adopters), with any luck things will be in a much better place when Synthesia 10.5 goes out the door and some of these fires will be put out! I'm hoping for a quieter inbox.
Nicholas
 
Posts: 11668

Postby KDN77RUS » 02-26-18 7:26 am

Now I can change the color of the cursor in version 10.5 (4442) ?
KDN77RUS
 
Posts: 20

Postby Nicholas » 02-26-18 8:57 pm

That will be in the next dev update. (This most recent "Progress Update!" in the post just before yours was just an informational update.)
Nicholas
 
Posts: 11668

Postby Isaackv » 03-05-18 2:40 pm

Hello, if I have selected a song and then go to "Both hands" or another button via "Practice the tune", the program crashes. I downloaded the version R4442 and also copied the Color.xml into the directory to the other XML files.
Isaackv
 
Posts: 4

Postby Nicholas » 03-05-18 2:53 pm

Is there an error message when it crashes? Or a crash report file saved to your desktop? If you could attach that crash report to your reply here, that would be helpful! Thanks.

EDIT: Never mind. I just spotted it in our crash database. I'm looking into it now.

EDIT 2: Hmm, the crash site is a little later on after the real problem happens. (Imagine a train that derailed, but takes a little while before it actually crashes into something. It's easy to see where it crashed, but it's a little trickier to find the problem in the track that caused the derailing in the first place.) Could you tell me a little more about your setup?

  • Is this happening with all songs or just a particular one?
  • Do you have a keyboard connected?
  • Does it still happen if you move that colors.xml out of the data folder temporarily?
  • Does it still happen with other menu choices besides Both Hands?
Thanks!
Nicholas
 
Posts: 11668

Postby KDN77RUS » 03-06-18 12:51 am

perhaps it
Attachments
screenshot_2.JpKzg (1).png
screenshot_2.JpKzg (1).png (131.3 KiB) Viewed 3142 times
Screenshot_1.png
Screenshot_1.png (93.86 KiB) Viewed 3280 times
Last edited by KDN77RUS on 03-09-18 7:09 am, edited 1 time in total.
KDN77RUS
 
Posts: 20

Postby Isaackv » 03-06-18 1:24 pm

Hello Nicholas,

As for your questions - as I do not speak English I always have to take the google translator - so I hope to always understand your questions

- It happens with many songs - I have not tested all
- Yes, I connected the Kawai VPC1
- Yes, even the color.xml has been taken out, the error occurs
-Yeah, it's on all buttons
-I found a dump file and settled it.

Greetings, Karsten
Attachments
Synthesia r4442 Crash.dmp
den gewünschten Crashdump
(345.66 KiB) Downloaded 81 times
Isaackv
 
Posts: 4

Postby Isaackv » 03-06-18 1:25 pm

Unfortunately I can not see the Spoiler of KDN77RUS
Greetings, Karsten
Isaackv
 
Posts: 4

Postby Nicholas » 03-09-18 12:41 am

Hmm, well, I fixed the symptom. That will show up in the next development preview. Hopefully that new version will shed some light on the root cause of the problem.
Nicholas
 
Posts: 11668

Postby KDN77RUS » 03-09-18 3:17 am

Isaackv wrote:Unfortunately I can not see the Spoiler of KDN77RUS
Greetings, Karsten

My spoilers are made by Nicholas.
I do not see them either, and I can not open them)
KDN77RUS
 
Posts: 20

Postby Angelos58 » 03-09-18 4:15 am

iOS?
Angelos58
 
Posts: 47

Next

Return to Development Updates

Who is online

Users browsing this forum: No registered users