Synthesia on Android emteria.OS/Raspberry Pi

Have questions? Just saying hello? This is the place.
No explicit, hateful, or hurtful language. Nothing illegal.

Postby olkhov » 12-23-18 7:32 am

Last edited by olkhov on 12-29-18 7:59 am, edited 1 time in total.
Posts: 26

Postby matthacker » 12-29-18 4:30 am

DECEMBER 26, 2018 AT 10:14 PM
Hmm when I try to follow this I get it installed with the apk (I dont install google play)

but synthesia keeps forgetting my settings and there are no playback trough the cable to my keyboard? You know what that could be ?

DECEMBER 27, 2018 AT 7:22 PM
Installing the apk worked for me, but not quite – I could not unlock Synthesia, it was complaining about missing internet connection Asked Nicholas – he said unlocking requires Google Play.

Regarding forgetting settings – not sure, maybe I saw that too. But at the end everything works fine. I did install Google Play – it was a bit painful, after the installation everything became rather unresponsive, the Google Play was busy with some downloads for quite long time, maybe 20-30 hours. Now everything is working.

Connecting piano – I connected it to one of RPi’s usb host ports, not to the micro-usb. RPi does not support OTG afaik.

DECEMBER 28, 2018 AT 11:31 PM
I have now installed it through GApps, now it does not forget any settings. But…

When I connect my piano (Yamaha DGX-620) then it finds it and when I preview the song it plays the song… but when I go into the song, then it doesn’t register my piano. Do you have any clue to what that is ?

DECEMBER 29, 2018 AT 8:02 AM
Good to hear about your progress. Regarding your piano connection – could you please share a screenshot of your Synthesia Settings?
Another question – what do you think if we move this whole discussion to the Synthesia forum?
Posts: 11

Postby matthacker » 12-29-18 4:36 am

have added image as an attachment here :)

My piano has output USB B as output
synthesia settings
48430172_2260939074178701_8068704490603151360_n.jpg (209.09 KiB) Viewed 4346 times
Posts: 11

Postby olkhov » 12-29-18 8:01 am

Settings look the same as mine. Did you tried Android midi driver instead of the built in one?
Posts: 26

Postby matthacker » 12-29-18 10:13 am

Yes I have tried that aswell.

I will try with linageos for raspberry pi now
Posts: 11

Postby matthacker » 12-29-18 10:49 am

what version of emteria are u using?
Posts: 11

Postby olkhov » 12-30-18 4:25 am

I used the Emteria.OS_Installer-v0.6-13.AppImage installer - Android 7.1.
Posts: 26

Postby olkhov » 12-30-18 4:33 am

I am curious to hear how lineageos performs. Because at the end I should admit that I am not quite satisfied with emteria.OS performance on Raspberry Pi 3 B. Sometimes it becomes less responsive, sometimes crashes. That might be Google Play presence on the box indeed, together with limited memory size.


I have a feeling that either network speed (using wifi), or sd-card speed, or both are not at the best level in emteria.OS.

I am looking at alternatives, Nano Pi 4M looks good here:

This one looks very interesting: - international version comes with Android TV 8.0, Google Play included. I am curious if it is possible to install Synthesia on this box from Google Play store?
Posts: 26

Postby matthacker » 01-02-19 2:17 am

I'm gonna try again with lineageOS, but it was a bit slow.

But I have tried Emteria once more, and the same happens.

It finds the keyboard, but after a short while the input/output of that piano just doesn't work.

I will try with another piano later this week, to see if the error is the same. But still it does work proper on my samsung galaxy s7 edge.
Posts: 11

Postby matthacker » 01-03-19 6:00 am

No luck with lineageOS. It is the same result :-/ hmm. wonder if it is my piano ? though it works on a windows computer and my samsung galaxy.

are there any specific changes from Model 3 B and Model 3 B+ ?
Posts: 11

Postby olkhov » 01-03-19 1:20 pm

matthacker wrote:No luck with lineageOS. It is the same result :-/ hmm. wonder if it is my piano ? though it works on a windows computer and my samsung galaxy.

are there any specific changes from Model 3 B and Model 3 B+ ?

Just thinking out loud:
- RPi 3b/3B+ - I do not know, I'm running it on RPi 3B
- what Android version is your Samsung Galaxy?
- I'd probably try other USB cable, or is it the same (+OTG adapter) you use with the Galaxy?
Posts: 26

Postby olkhov » 01-03-19 1:22 pm

matthacker wrote:...lineageOS...

So, what's your impression of the lineageOS? If possible - could you please share a screencast?
Posts: 26

Postby matthacker » 01-04-19 2:17 am

Well the LineageOS that I have tried is this:

and I think it is a bit buggy at the moment, lots crashes( has stopped working dialogs)

Well I have an update on the Emteria part.

I tried with a M-Audio Keystation 49, and it works with that.

The only difference between those two that I can think of is that it cannot produce sound itself. So only the input is used in synthesia (detect finger presses)

So maybe I should try only enabling the input for my main keyboard, and if that works, maybe it doesn't get enough power? So..

I ordered a charger specific for raspberry pi, to be sure that it gets the power it needs, so lets see if that is the problem. (am using charger from samsung galaxy atm)

Screen cast is not possible right now, since I wrote the sdcard with rasbian again..

Another reason I think that power to the rasp might be the issue is, I told that my pianoworks with Windows computer and also various android tables/phones.

I installed Rasbian on the SD card, installed Exagear, wine, Alsa, Synthesia. And there it also registered my piano, but again suddenly it disappears. (though you can use synthesia this way, I wouldn't recommend it, it is very slow on Rasp Pi 3 B+ :-/)
Posts: 11

Postby matthacker » 01-05-19 7:14 am

One update more.

I found out that I can also have input only from my own piano (key presses), but sending output to the piano from Synthesia some times fails. But I can never have both enabled at the same time to the piano :-/ hope it is only this piano, because then I might be able to buy another piano :)

Have any idea why I only can have one Input/output at the time to the piano?
Posts: 11

Postby Nicholas » 01-07-19 11:52 pm

For what it's worth, I've never heard of only one direction working at a time in a MIDI keyboard before. Like, in thirteen years and tens of thousands of emails & forum posts from users having trouble with their keyboards... this hasn't ever come up.

How strange!
Posts: 11870

Postby matthacker » 01-09-19 3:45 pm

If you want any information I will try and get it for you..

I guess its maybe compliance of the midi driver with my old piano ? its almost 16 years old. but then again, there is a standard of how to implement driver so..
Posts: 11

Return to General

Who is online

Users browsing this forum: No registered users