Synthesia not accepting more than 2 keys at a time

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
Tim1Blau
Posts: 5

Post by Tim1Blau » 02-02-20 7:57 am

Hello i experience an issue with Synthesia. If I try to press 3 keys at a time, the sound gets interrupted. When I use other software, like pianofromabove, I am able to press as many keys as I want, without any issues. MIDI-OX shows me, that there is an 'All Notes Off'-command, whenever I press more than two keys on channel 12,13,14,15,16. Everything else seems to be happening on channel 5. Output is working fine but is interrupted, when playing Synthesia in practice-mode. (Windows 10, Synthesia 10.6.5383)

Nicholas
Posts: 12185

Post by Nicholas » 02-02-20 12:28 pm

Which keyboard are you using? Is the "All Notes Off" coming from the keyboard or from Synthesia?

Tim1Blau
Posts: 5

Post by Tim1Blau » 02-03-20 4:39 pm

I'm currently using my old bontempi pm694. The "All Notes Off" comes form the input, so the keyboard, the adapter or the driver I guess, but the sound output is working just like it should and input somehow seems to be working fine in PianoFromAbove. I have linked an image of MIDI-OX, where I tried to press 3 keys at the same time. The All Notes Off command appears right after the third key has been pressed.

Nicholas
Posts: 12185

Post by Nicholas » 02-04-20 1:27 pm

(The MIDI-OX image link didn't seem to make it through. That would be useful to see!)

I'm guessing your PM694 is doing this as a way to work around very limited memory. After you release the third note, is there still a regular Note Off sent too? Or is the All Notes Off the only message sent? Internally it might only be able to track a (very small) handful of currently-held notes. After more than that are pressed, the best it can do (instead of tracking each) is to say "turn them all off". That's my guess anyway.

I'm also guessing the reason PianoFromAbove seems to be "working fine" is because it ignores "All Notes Off" messages and just leaves the notes running forever. With piano notes, that can be fine. With any MIDI instrument that sustains forever (violin, flute, etc.) this would quickly lead to a mess.

That said, if regular "Note Off" messages are also being sent and the "All Notes Off"s are just extraneous messages, there may be an option in the keyboard's settings to disable them.

Tim1Blau
Posts: 5

Post by Tim1Blau » 02-05-20 3:40 pm

midiox.PNG
midiox.PNG (398.87 KiB) Viewed 209 times

Tim1Blau
Posts: 5

Post by Tim1Blau » 02-05-20 3:44 pm

This Picture shows me pressing 3 keys at once. After the third key has been pressed, the All Notes Off commaand appears and after that I release the keys.
Is there a way to ignore these All Notes Off messages in Synthesia, or is there an external programm, that lets me filter these commands?

Nicholas
Posts: 12185

Post by Nicholas » 02-06-20 2:46 pm

That is very strange that it's sending both! There... isn't any reason for it to send an "All Notes Off" if it can track the regular "Note Off" messages.

The good news is MIDI-OX is a great tool for this kind of filtering.

Actually, the "MIDI Filter" window may be even easier than the "Data Filter" window, so long as you just make sure to check the "Filter out Data as well as Display" checkbox there. (The rest of the steps with virtual MIDI drivers, etc. will be the same.)

Tim1Blau
Posts: 5

Post by Tim1Blau » 02-07-20 5:47 am

Wow, it actually works now. Thank you so much for your help!

Post Reply