Play incorrect notes at full volume

Synthesia is a living project. You can help by sharing your ideas.
Search the forum before posting your idea. :D

No explicit, hateful, or hurtful language. Nothing illegal.
Post Reply
stepancheg
Posts: 6

Post by stepancheg » 12-27-11 10:25 pm

Currently incorrect notes could be played at half volume (default) or turned off at all.

Please, add an option to play incorrect notes at full volume. I'd like to find out my errors by hearing wrong tone, not by hearing muted sound.

Anyway, thanks for Synthesia, it's great!

Nicholas
Posts: 11960

Post by Nicholas » 01-04-12 5:41 pm

This isn't a bad idea. At the very least for rhythm practice. Sort of like a better version of a metronome.

(In melody practice it's moot because you have to hit every note and recital is the thing you don't click until you can play all the notes.)

handstand
Posts: 1

Post by handstand » 08-09-14 5:15 pm

Did you ever end up doing this? I would appreciate having that as a possibility as well and can't find any mention of it any more recently than this post.

Thanks so much for the game, it's really well done and easy to use :)

Nicholas
Posts: 11960

Post by Nicholas » 08-10-14 5:09 pm

This hasn't made it in yet, but what's really going on between "full volume" and "half volume" is that the song's notes are at some high velocity level while your input is quieter. For a nice workaround, try this:

Settings -> Gameplay -> Note Loudness -> Match Your Input.

After that, all notes (including your mistakes) will be at the same volume.

C0rn3j
Posts: 3

Post by C0rn3j » 09-04-19 5:47 pm

If I understand correctly, I can either "Get loudness from song", which will make Synthesia ignore how hard I press the keys, or I can select it to "Match your input", which will play as loud as I hit the keys, but if I hit the wrong key I will have no indication that I have made a mistake.

I think the ideal solution would be to have an extra checkbox option "Play wrong notes quieter", to specifically turn this behavior on and off while still letting people choose between matching the input vs letting the MIDI define the volume of keys.

EDIT: Or add an option to play an error sound along with the incorrect note at full volume? My use case simply is to play notes at my own velocity but still be able to have an audio cue for mistakes.

Nicholas
Posts: 11960

Post by Nicholas » 09-05-19 3:56 am

Hmm, with either of those settings Synthesia shouldn't be sending a note out at all if it doesn't match one of the song's notes. (In this case, the "error sound" is silence.)

You may be hearing your keyboard's own sounds that also play when you strike a key. Choose your keyboard from the Settings --> Music Output list and try enabling the "Prevent 'local' notes" setting there. Many keyboards will respond to that MIDI message that basically says "don't produce any sound when someone strikes a key; only produce sound when a MIDI note arrives through the MIDI port."

C0rn3j
Posts: 3

Post by C0rn3j » 09-08-19 3:07 pm

Let me describe my setup a bit better -
I've keyboard speakers disabled (Yamaha P-125), and I only have the sounds enabled via Synthesia through PC speakers, so I'm not hearing my keyboard noise.

Turning on "Prevent local notes" doesn't seem to do anything at all, both the keyboard and PC speakers will produce noise no matter if it's on or off.

I'm playing "Practice the Melody" mode.

Nicholas
Posts: 11960

Post by Nicholas » 09-10-19 2:18 am

I am so sorry! The misunderstanding was completely my own. For whatever reason I had gotten it into my head that Synthesia only plays correctly-matched notes. Of course you're hearing your own (non-matching) notes at full volume.

(And if you've already got your keyboard speakers muted, the "Local" option won't have any effect.)

I wonder. Maybe this should be a new option. Something like Settings --> Gameplay --> "Incorrect Note Volume" with a slider that defaults to 100%. Then you get lots of variability: 100% is how things work today. 0% would be "don't play incorrect notes" (like my misunderstanding just now). And anything in the middle would be the quieter incorrect notes you suggested.

C0rn3j
Posts: 3

Post by C0rn3j » 09-11-19 6:32 pm

>(And if you've already got your keyboard speakers muted, the "Local" option won't have any effect.)
I of course unmuted the keyboard to test if it works or not, but I am running Synthesia mainly on Linux, so it might be a wine issue, or the keyboard simply doesn't have the feature.
EDIT: The feature works, I was using the wrong output to test it.

The slider you suggested would be perfect!

Post Reply