Can't use my keyboard as MIDI out? (MIDI Feedback loop?)

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).

  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.

Postby SeiferLeonheart » 10-28-16 2:27 pm

Hi everyone!

I've been trying for days to solve this issue, finally gave in and hope someone can help. I'm sorry in advance for the size of the text, but it seems like a very specific issue and I don't know how to explain in less words, lol. Here's the issue:

My adapter works fine (it is not those cheap ones that aren't recommended) and I can play normally on Synthesia, BUT, in the middle of a song, one or more notes just get stuck. Synthesia freezes and the proccess on windows task manager can't be "killed" (closed). All I can do at this point is reboot. Trying to play again, causes the same issue, but it is not exact the song or the part of each song that the problem occurs.

I've googled a lot, but couldn't find this specific issue. It looks like a feedback loop, but disabling my "local controller" on the keyboard haven't solved the issue.

As for specs, I'm using a Yamaha PSR 550, a fairly powerful gaming rig (R9 390X, FX 8350, 16gb ram, etc) and my adapter is called "Prelude Conecta", its locally made in my country, and it is fairly reputable.

Also, I've noticed that if I use the Windows MIDI controller (Wavetable, I believe) there are not freezing issues, but the delay makes it very hard to play and sounds way worst than using the keyboard as an output.

Thanks in advance for the help!
SeiferLeonheart
 
Posts: 2

Postby jimhenry » 10-28-16 9:28 pm

Try disabling (Off) "My Notes" in the Synthesia Music Output Settings and turning on "local controller" for your keyboard. This is just a guess so let us know if this helps or not.
Jim Henry
Author of the Miditzer, a free virtual theatre pipe organ
http://www.VirtualOrgan.com/
User avatar
jimhenry
 
Posts: 1747
Location: Southern California

Postby SeiferLeonheart » 11-02-16 3:34 pm

I'm sorry about the delay to answered, I had very little time to stay at home in the past few days.

I think you may have solved the issue. I've only managed to reproduce it in a single one of my MIDIs. Before, if I played many keys all at once, it would freeze with 100% of certainty, now I was playing all the keys I could with both hands and haven't had a single "note stuck" issue, except this single MIDI file, but it was while playing literally with one finger, so it's different from before. For now, I'll blame the file and play (more like "try") everything else.

Thank you so much! =)
SeiferLeonheart
 
Posts: 2

Postby jimhenry » 11-02-16 9:04 pm

Keeping my fingers crossed for you!
Jim Henry
Author of the Miditzer, a free virtual theatre pipe organ
http://www.VirtualOrgan.com/
User avatar
jimhenry
 
Posts: 1747
Location: Southern California

Postby Gouldin » 08-23-18 3:06 pm

Thanks to the previous folks who posted this, worked perfect for me :)
Gouldin
 
Posts: 7


Return to Help and Bug Reports

Who is online

Users browsing this forum: No registered users

cron