How can I use my other digital pianos voices with Synthesia

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).

  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.

Postby Spongy » 05-17-18 4:59 pm

Hi All,
So I am new to using Synthesia. I have a Yamaha P255. I have the piano hooked up via a usb cable, and have tried both a PC and android.

When I change the voice on my piano when sythesia is running, I get a mix of the voice I selected and a piano voice, It seems like synthesia is forcing a piano voice to always be on.

In settings the music input is set to digital piano1, and if I set the music output to what is listed there as digital piano 0, I get a mix of the two voices as stated above. If I turn this output to off then I just get my pianos voice to what ever I set it to but then synthesia will not play an acompanying hand.

How can I set up synthesia to just use a voice that I set at my piano? So I can practice using any voice I want that my piano offers?

Posts: 4

Postby Nicholas » 05-25-18 3:40 am

The best way to do this is by telling Synthesia not to mess with your keyboard's voices at all. Head over to Settings --> Advanced --> Instrument Change Messages --> Filtered out.

(Today -- in Synthesia 10.4 -- there is a known issue where the reset between screens still causes instruments to be reset back to zero, or piano. This will be fixed in the upcoming 10.5 release. If you're interested, there is already a 10.5 beta version available for PC and Android with this problem solved. More information, here.)

The other part of the problem is the double note. When you strike a key on your keyboard it naturally plays that note. Then, when Synthesia "sees" your input, it echoes it back out to all of your Music Output devices. That leads to two of the same note in rapid succession.

The way to avoid that is to change one OR the other of the following settings when you choose your keyboard from the Music Output list on the Settings screen:
  1. Disable the "My Notes" option.
  2. Enable the "Prevent 'local' notes" option.
The former will eliminate Synthesia's duplicate note. The latter (if supported by your keyboard) will eliminate the automatic note played reflexively by your keyboard.

(Setting both of those will eliminate BOTH notes and leave you in silence! :lol: )
Posts: 11867

Postby monkel » 05-31-18 2:34 am

Is there a way to play a multi voice midi (drums, strings etc.) and enjoy that part, while having synthesia apply the instrument change message filter to the voices defined for right and left hand playing?

Otherwise it seems to me, that I can only play play all in piano sound or all general midi sound.
Posts: 184

Postby Nicholas » 05-31-18 3:02 am

That sounds like the job for a more advanced filter. Something like MIDI-OX's Data Mapping feature could handle that without much trouble if you routed Synthesia's output through that.

You would just set up a pair of "Discard" filters for "ProgChg" messages that matched the left & right hand channels (shown on the "Hands, Colors, and Instruments" screen). That would keep all of the other instruments, but throw away any changes on those two.
Posts: 11867

Postby monkel » 06-01-18 12:33 am

Perhaps I don't understand the MIDI messaging format well enough or how Synthesia works, that it would need external support to do this.

Here's what I'd thought might / should be possible:

Keyboard connected as in- and output, all sounds to be produced by the keyboard.
Synthesia uses the keyboard output to display the playing and work with it.
The keyboard produces sound from the pianist playing with the sound configured right now.
Additionally Synthesia sends the background tracks to play by the keyboard, e. g. via general midi assigned voices.

Do you need to send Instrument Change Messages for all tracks? Or could you offer a choice of "piano local" instead of the General Midi selection when in the "Hands, Colors and Instruments" menu so that one could choose that for left & right hand?

A workaround seems to be that if I pause Synthesia and choose the builtin voice I want and then continue it seems to work, probably because the instrument change message doesn't get sent more than once?
Posts: 184

Postby Spongy » 06-04-18 3:49 pm

Thanks Nicholas, for that help!
Posts: 4

Return to Help and Bug Reports

Who is online

Users browsing this forum: No registered users