Both hands playing uses wrong octave

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).

  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.

Postby Jarzka » 07-02-18 2:34 pm

Hi again

When playing the attached song with only left or right hand, everything works ok. However, when I switch to play with both hands, synthesia moves both tracks one octave higher. I can still play it with my physical keyboard, but it sounds wrong since I'm really playing it one octave higher. Why does this switch happen?

More detailed explanation:
In the file correct.png, I'm playing with right hand track only. I'm pressing the middle-D key on my keyboards and it works as as I expect.
In the "wrong with both hands", I play the same song with both hands. I'm pressing the same middle-D key on my keyboard, but for some reason Synthesia expects me to play it one octave higher. This sounds wrong.
Attachments
While Your Lips Are Still Red (piano 5).synthesia
(242 Bytes) Downloaded 15 times
While Your Lips Are Still Red (piano 5).mid
(11.28 KiB) Downloaded 17 times
wrong with both hands.png
wrong with both hands.png (291.53 KiB) Viewed 307 times
correct.png
correct.png (298.41 KiB) Viewed 307 times
Jarzka
 
Posts: 8

Postby Jarzka » 07-02-18 2:49 pm

I think I realised the problem. There is one extra low note on the left hand track that I'm unable to play with my current keyboard. That's the reason why Synthesia moves everything one octave right to make it possible to play this song. But it still sounds wrong.

Anyway, I removed that one low note and now I can play the song just fine.
Jarzka
 
Posts: 8

Postby Nicholas » 07-08-18 2:37 pm

Another way to prevent Synthesia's "helpful" behavior in this case is by changing Settings --> Gameplay --> Keyboard Octave --> Manual Only.
Nicholas
 
Posts: 11707


Return to Help and Bug Reports

Who is online

Users browsing this forum: No registered users

cron