(Andriod) Song doesnt play on the "song waits for you"

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).

  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.

Postby evo » 11-28-18 10:04 pm

Any song I chose doesn't play when I have my keyboard hooked up, even when I press play, it says its un-paused yet doesn't start. It works on all of the other modes, except this one (which is the one I really want).

I am on version 10.5.4818
I am currently using an Android phone, update 6.0, Model Life One X (BLU)
evo
 
Posts: 10

Postby Nicholas » 11-29-18 4:05 am

This sounds like it might be a new bug. How interesting.

The timeline doesn't move at all? If you tap someplace on the timeline to jump to a new position in the song, does it stay there (also stuck) or does something different happen?
Nicholas
 
Posts: 11752

Postby evo » 11-29-18 9:19 am

Yeah I can press on the time line, but still, it will just stay there for some odd reason, and only play the sound of a note if there is a note there, also showing the notes, just not moving.
evo
 
Posts: 10

Postby Nicholas » 11-29-18 11:19 pm

How curious. Which model keyboard are you using? Does it have a pitch bend wheel? Have you set any custom shortcuts on the Settings --> Shortcuts screen?

(A while back, pitch bend wheels that didn't quite return to center could change the song's speed and sort of break melody practice that way. We ended up having to remove that as the default for the song navigation shortcut because there were enough loose wheels out there.)
Nicholas
 
Posts: 11752

Postby evo » 11-30-18 7:35 pm

My keyboard is the Yamaha PSR-225. It does not have a pitch bend wheel, and I dont have any custom settings, i tried uninstalling, deleting all my shortcuts, new profiles. Nothing found so far :/
evo
 
Posts: 10

Postby Nicholas » 12-02-18 6:31 am

I'm hoping to release a small bug-fix update for Android in the next couple days. If that one doesn't solve the problem, with any luck it will let us collect a little more information about it. Sorry for the wait in the meantime!
Nicholas
 
Posts: 11752

Postby evo » 12-08-18 1:38 am

sadly does not work as of the new update. I dont 100% need it, but would be nice. Thank you for trying to work on it right away tho :D
evo
 
Posts: 10

Postby Nicholas » 12-08-18 9:28 pm

Assuming you didn't change the new "Music Device Connection Method" setting in 10.5.4830, that sounds like it's not working with either the built-in USB-MIDI driver (which is again the default) or the Android M MIDI method (which had been the only one available post 10.5.4818 on newer devices until 4830).

That was the "more information" I had mentioned last time. How interesting! I'm still completely stumped why it would only be broken in one mode.

Just as a double check: when you said "any song" in your very first post, does that include the songs built into the app? Or do you have a lot of your own, custom songs in the app, too? (The built-in songs in the Easier, Easy, Medium, etc. categories are usually a nice test because they are just about the simplest MIDI files you can imagine. Most of them are very little more than a list of note on/off messages. So they're good for debugging things while being able to rule out strange messages in a particular song.)

Also: what about Settings --> Gameplay --> Incorrect Notes --> Are Ignored? Does that make the timeline proceed normally?
Nicholas
 
Posts: 11752

Postby evo » 12-08-18 10:31 pm

I downloaded songs I wanted to play, but yes, any song (even the ones in the app) do not work on this mode. No clue why. Thanks for your constant help though :D
evo
 
Posts: 10

Postby evo » 12-08-18 10:57 pm

O WAIT, BRO IT WORKED. NOT SURE WHAT, BUT AFTER I DID WHAT U SAID FOR SETTINGS, I RESTARTED AND IT WORKS ;O.

Thank you so much xD <3
evo
 
Posts: 10

Postby Nicholas » 12-08-18 11:52 pm

How interesting. That would imply that Synthesia thinks you're holding a note down at all times. By default, holding an incorrect note stops Melody Practice from continuing. The setting you changed lets it continue despite incorrect notes.

That makes me wonder what sorts of messages Synthesia is seeing from your keyboard. Which model USB-to-MIDI adapter are you using with your PSR-225? It might be sending junk input. Especially if it looks like any of these.
Nicholas
 
Posts: 11752

Postby evo » 12-09-18 12:03 am

Im pretty sure it is this one, https://www.amazon.com/dp/B07CC4T5RJ/re ... B000JLU26W

I have had it for a while now, and works well (like a year almost)
But yeah, hopefully u can figure it out for future people :D
evo
 
Posts: 10

Postby evo » 12-09-18 12:16 am

I might make this another separate post, but I have another problem xD. very minor, but when i try to connect my keyboards own keys, (how high and low it can play), the app thinks I can play a super high octive note, when in reality, my keyboard cant.
You see, the app asks you to play the lowest note possible, so when I do it does see that its the lowest note, and auto corrects it, but thinks I can play superhigher notes, not sure if its just my keyboard, but a feature to be able to select highest and lowest notes would be nice.

Again, Thanks :D
evo
 
Posts: 10

Postby Nicholas » 12-09-18 11:41 pm

Yeah, that sounds like the same problem: my guess is that the adapter (or the keyboard, I suppose) is producing some incorrect/buggy MIDI data that makes it appear some out-of-range note is constantly being held. That would explain both situations.

I've been meaning to have Synthesia reject out-of-range note input for a while now. Anything outside the typical A0 through C8 range on an 88 key keyboard should simply be ignored. That should fix problems like these, wonky adapter or not. :)
Nicholas
 
Posts: 11752

Postby evo » 12-10-18 1:22 am

okay, hope to see the update soon :D

Other feature is working just fine (song waits for you)

Thanks
evo
 
Posts: 10

Postby Nicholas » 12-10-18 2:08 am

... actually, I just pushed a new build to Google Play a few minutes ago with that fix (and several others). :D

When you get the update (and it says 10.5.4841 at the lower-right corner of the title screen), hopefully both problems will be resolved. You shouldn't need to change that setting anymore and there shouldn't be any extra notes being detected way outside the usual 88 key range.
Nicholas
 
Posts: 11752

Postby evo » 12-10-18 10:14 pm

you are too good nick xD
evo
 
Posts: 10


Return to Help and Bug Reports

Who is online

Users browsing this forum: No registered users