Crash report

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).

  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.

Postby marthart » 02-22-19 6:42 am

Hi. Wont start anymore.
Re installed. but nothing.
got a crash report but wont up load says to big.
marthart
 
Posts: 23

Postby marthart » 02-22-19 8:43 am

Tried to sent an email with file to.

support@synthesiagame.com.

But bounced back "Unknown"
marthart
 
Posts: 23

Postby Nicholas » 02-22-19 10:28 am

Hmm, that's the right email address. (With four new messages arriving in the past hour! :? ) I wonder if it bounced back because the attachment was too big. Hrm.

I just bumped the upload limit on the forum. With any luck, it should upload here now.
Nicholas
 
Posts: 11858

Postby marthart » 02-23-19 2:49 pm

I think that has up loaded now.

I did send it with email though and it didnt bounce back.

I was my fault with the email, I copies/paste from your email above but there is a dot and the end of .com and I didnt notice it.
Attachments
Synthesia r4900 Crash.dmp
(1.68 MiB) Downloaded 3 times
marthart
 
Posts: 23

Postby Nicholas » 02-25-19 1:29 pm

It looks like this crash is in your Intel graphics driver (ig7icd32.dll) when Synthesia is trying to initialize OpenGL.

Would you happen to know if you updated any drivers recently? (Or, if your video driver is very out of date?) Did you recently make any hardware changes to your computer?
Nicholas
 
Posts: 11858

Postby marthart » 02-25-19 1:54 pm

Yes I have just put one of these on.

Toshiba 14" inch USB-Powered Mobile LCD External Monitor PA39223U-2lc3

Powered through usb and sits on the music stand like a thin tablet.
There is software for it called display link.
marthart
 
Posts: 23

Postby marthart » 02-25-19 2:37 pm

I up dated the card software and it still did not work.
Took out the Toshiba monitor software and synthesia worked again.
Meanwhile windows intalled the Toshiba software on its own and it all still works.

this stuff could drive you nuts. :D

Thanks for pointing me in the right direction.
marthart
 
Posts: 23

Postby Nicholas » 02-25-19 4:23 pm

Ah ha! Thanks for the information. I wonder if their support for hardware accelerated (3D) apps like Synthesia isn't quite perfect. Sorry for the inconvenience!

Those sorts of USB devices have to essentially "pretend" to be real video hardware, which means a lot of bending over backwards for DisplayLink. (I'm guessing a lot of that work would have to be done on the CPU instead of in your real video hardware, which would lead to things like more power consumption and faster battery consumption if you're using a laptop.)

If you have any other video outputs on your computer (HDMI, DVI, DisplayPort, etc.) connecting a monitor to any those (instead of USB) would be the way to go. That kind of port gets to use the video hardware directly, which makes things easier for everyone and will allow better compatibility with apps like Synthesia.
Nicholas
 
Posts: 11858

Postby marthart » 02-25-19 5:32 pm

I didnt know that it would be possible to use say a usb to hdmi connector.

It has 2 usb via a spliter as one will be used for power.

will have a look into it.
marthart
 
Posts: 23

Postby Nicholas » 02-27-19 11:10 am

Er... sorry for the confusion. I meant more if you had a direct connection, say, an unused HDMI port on your computer that you could connect directly to an HDMI monitor.

Unless you're using the very latest type of USB port (3.1 gen 2) or something like Thunderbolt 3, they weren't really designed to carry video the way these external monitors are doing things (which is why they tend to cause the sort of trouble you're running into).
Nicholas
 
Posts: 11858


Return to Help and Bug Reports

Who is online

Users browsing this forum: No registered users