No name notes Sharps and Flats

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
Posts: 2

Post by WelderMusic » 07-30-19 2:38 pm

Hello. I'm new to the forum. I would like to ask a question. Within the program synthesia appear the names of the notes + sharp and flat. However, when I render the file to .web, only the natural notes appear. Names that contain # (sharp) and b (flat) do not appear in the rendered file, as in the images below. How can I solve this problem?
File Youtube
Screenshot_1.jpg (120.15 KiB) Viewed 135 times
File Synthesia
Screenshot_2.jpg (220.08 KiB) Viewed 135 times

Posts: 11911

Post by Nicholas » 07-31-19 4:20 am

Sorry, this is a consequence of the most recent version of the video creator being older than the most recent release of Synthesia.

The short answer is to:
  1. Download Synthesia 10.4 (from the "Older Versions" section).
  2. In that version: Settings --> Gameplay --> Note Labels --> Show All.
  3. Close Synthesia 10.4.
  4. Launch the video creator and generate your video.
The longer explanation is that the "Note Labels" default option changed between 10.4 and 10.5. So when you close anything newer than 10.4, it sees that "Note Labels" is set to the default value ("Show All"), so it doesn't write that setting out to the file. But then when the video creator (based on 10.4) loads the settings, it says "Oh, there isn't a "Note Labels" setting in this file, so I'll just use the default ("Use Song's Key") value instead".

Performing the same steps (and altering the option manually to not use the default) with a matched version pair will make sure it's not lost and all the labels should show up correctly.

Sorry for the confusion!

Posts: 2

Post by WelderMusic » 07-31-19 10:35 am

Thank You!

Post Reply