losing all stats and program launching as if first time

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
sholland
Posts: 3

Post by sholland » 10-01-19 10:46 am

Hi,

Just wanted to post something on here to see if anyone else is having an issue that's happened recently.
I've been using Synthesia for Windows 10 for around a year with no problem whatsoever and I love it, its really got me back into playing the piano after having a 10yr break! :)

For the past couple of weeks though for some strange reason the program it fully reset, as it in opens up as normal but then its like the first time its ever been opened, all my settings reset, song progress, edited LH/RH on midi songs, profile and I have to enter in my unlock code again.

The program works fine other than that and works for a random amount of time, sometimes a day, had a week prior to posting this but sometimes it happens as soon as the program is closed and relaunched.

running latest version of windows 10 home 64 bit. is this happening or has happened to anyone else?
thanks in advance
Sean

st5555
Posts: 32
Location: Vermont

Post by st5555 » 10-01-19 8:11 pm

It happened to me once.
Here's my post:

viewtopic.php?f=6&t=9329

My assumption was confirmed on how to backup Synthesia data files which I noted at the end of my post.

Thankfully has never happened again but I still backup that folder every now and then.

No idea what caused it or how to prevent it.

In order to see the folder you'll have to have "hidden items" checkmarked on the view tab of windows explorer.

Good luck!

sholland
Posts: 3

Post by sholland » 10-02-19 9:47 am

Hi Mate,

Thanks for coming back to me with the advise, just taken a look at your post from last year and thats what I started to do a couple of days ago, back up the app roaming folder and then if it deletes all my data again I can paste it all back into the directory.

Still is a little annoying to have to do it (or remember too :lol: haha) but I'll take weekly back ups just to be safe.
Glad its not just me though but its certainly a weird one when I've been using for nearly a year without any issues.

Once again thanks for your help and glad to know the plan I've put in place is the right thing to do.

Sean

Nicholas
Posts: 11993

Post by Nicholas » 10-03-19 5:12 am

What you guys are describing is the oldest known bug in Synthesia. Like I mentioned in the other topic, this is something I've been trying to track down forever.

The root of the problem is that files are hard. (If you're interested in technology, that article is kind of scary because it illustrates just how fragile the house of cards is that everything else is built upon.)

After many years I've decided that sort of minutiae is outside my (desired) area of expertise and that I'd rather defer to a library maintained by someone else that has the time to care about that stuff. So starting a couple updates from now, I'm planning to migrate all of Synthesia's data files over to a SQLite database. They work very hard to keep their files reliable and recoverable, which means I will be able to focus my time on other things and hopefully this problem will be solved once and for all!

In the meantime, I'm very sorry for the data loss! That is always a terrible experience.

sholland
Posts: 3

Post by sholland » 10-04-19 7:17 am

Hey Nicholas,

Thanks for your reply too means a lot and shows you care about the community :)

Don’t worry about I run a web design company and know how much of a pain in the backside code is so I try to leave all the tricky coding to my business partner :lol:

Only really posted on here to see if it was an isolated issue on my machine, thought it could have been a recent windows update etc that had clashed somehow. I’ve set up an automatic weekly back up into google drive so at most I’ll only lose a little data if it happens again.

Keep up the good work this program really has changed my life and got me back into playing piano every day so I owe you a big big thank you for that!

All the best
Sean

Post Reply